Cannot change version of project facet Dynamic Web Module to 2 5

Cannot change version of project facet Dynamic Web Module to 2 5

This is very common error while setting up new project and its just take your extra time to fix it as you get error as below:

  • Cannot change version of project facet Dynamic Web Module to 2.5

Cannot change version of project facet Dynamic Web Module to 2 5

  • Solution: If you are using maven project please include below in your pom.xml file:

  • Also check core.xml as shown below should match:

Cannot change version of project facet Dynamic Web Module to 2 5

  • If still its not working then please change JDK version, Java compiler and project facet using this tutorial

One thought on “Cannot change version of project facet Dynamic Web Module to 2 5

Leave a Reply

Your email address will not be published. Required fields are marked *