Dynamic Web Module 3 1 requires Java 1 7 or newer

Dynamic Web Module 3 1 requires Java 1 7 or newer

This is biggest annoying error which working with Maven and using eclipse. Most of the cases this happens if you import existing project or if you are using some old configuration and you get error as below:

Dynamic Web Module 3.1 requires Java 1.7 or newer

  • Solution 1: If you are using maven please check build tag shown below in pom.xml file. As you see plugin has been configure to use JDK 1.6 with 3.1 version that’s why you are getting error:

  • To fix this please change to 1.7 as below and update your maven project (Right click project –> Maven –> Update project…)

  • Solution 2: If above doesn’t work then change java compiler version to 1.7:

Dynamic Web Module 3 1 requires Java 1 7 or newer

  • Change project facet version to 1.7:

Dynamic Web Module 3 1 requires Java 1 7 or newer

  • Change java build path of the project to use JDK 1.7:

Dynamic Web Module 3 1 requires Java 1 7 or newer

  • and finally check core.xml file and change as below:

Dynamic Web Module 3 1 requires Java 1 7 or newer

  • This should fix the issue.

Leave a Reply

Your email address will not be published. Required fields are marked *