Install Drools Plugin Eclipse

Install Drools Plugin Eclipse

Jboss Drools is Business Rules Management System (BRMS) which provide solution for web authoring, core Business Business Rules Engine (BRE) rules management application i.e. (Drools Workbench) and also Eclipse IDE plugin to do core development. To do fast development with Drool its good to have Drools integrated with IDE. This demo will show you how to install Drools plugin in eclipse.

  • Eclipse used: Eclipse Kepler (4.3). You are free to use any version of eclipse
  • First go to its release page http://download.jboss.org/drools/release/ to check out what are latest release available. We will install 6.1.0.Final stable version which was released on (03-Aug-2014 04:28) as mentioned on the web site. Click this link to go its home page:

Install Drools Plugin Eclipse

  • Click update site link:

Install Drools Plugin Eclipse

  • On your eclipse click Help –> Install New Software… –> click Add –> Copy URL from browser and paste on location as below (http://download.jboss.org/drools/release/6.1.0.Final/org.drools.updatesite/) and click OK

Install Drools Plugin Eclipse

Install Drools Plugin Eclipse

  • Select all as below then click Next:

Install Drools Plugin Eclipse

  • Click Next:

Install Drools Plugin Eclipse

  • Accept term and condition then click finish:

Install Drools Plugin Eclipse

  • You will see below its stared installing plugin:

Install Drools Plugin Eclipse

  • If you see warning click OK:

Install Drools Plugin Eclipse

  • Once its done you will be prompted to restart eclipse to take effect click yes:

Install Drools Plugin Eclipse

  • To check if it’s installed correctly or not click Window –> Preferences you will see Drools as below:

Install Drools Plugin Eclipse

  • Also check if Drools project creation wizard are available or not. Click File –> New –> Other and see for Drools:

Install Drools Plugin Eclipse

  • That’s it. Visit next tutorial to create Drools project in eclipse.
  • For more information please visit its official web site here

2 thoughts on “Install Drools Plugin Eclipse

  1. Hi

    I am trying to install drool 6.4.0.Final in eclipse Neon. I use the update site url download.jboss.org/drools/release/6.4.0.Final/org.drools.updatesite/ and it works fine. But once eclipse starts calculating requirements etc. it proceeds to a page which shows that

    Cannot complete the install because one or more required items could not be found.
    Software being installed: JBoss Runtime Drools Detector Developer Resources 6.4.0.Final (org.jboss.tools.runtime.drools.detector.feature.source.feature.group 6.4.0.Final)
    Missing requirement: JBoss Runtime Drools Detector 6.4.0.Final (org.jboss.tools.runtime.drools.detector.feature.feature.group 6.4.0.Final) requires ‘org.jboss.tools.runtime.core.feature.feature.group 0.0.0’ but it could not be found
    Cannot satisfy dependency:
    From: JBoss Runtime Drools Detector Developer Resources 6.4.0.Final (org.jboss.tools.runtime.drools.detector.feature.source.feature.group 6.4.0.Final)
    To: org.jboss.tools.runtime.drools.detector.feature.feature.group [6.4.0.Final]

    Can you please help me know what’s going wrong here or i am missing something.

    FYI Eclipse GEF plugin installed successfully.

Leave a Reply

Your email address will not be published. Required fields are marked *