Must override superclass method

Must override superclass method

While working with Java with Eclipse IDE you will see this compilation issue where all settings are correct. Usually this happens if you import new project, existing class to your eclipse worksapce. You will see below compilation issue:

Remove ‘@Override’ annotation

The method execute(JobExecutionContext) of type CronQuartzJob must override a superclass method

Must override superclass method

  • Solution: This issue happens if you JDK library has mismatch with compile version. To check this Right click project –> Build Path –> Configure Build Path… –> Java Build Path:

Must override superclass method

  • As you see above project build has been set to JDK 1.8 version. Now let’s check compiler version Right click project –> Build Path –> Configure Build Path… –> Java Compiler:

Must override superclass method

  • Above Java Compiler is still pointing to JDK 1.5 version. To match build path version please change it to 1.8 then clean your project problem should be fixed.

Must override superclass method

  • For more information please read Java documentation from Oracle here

Leave a Reply

Your email address will not be published. Required fields are marked *