org apache activemq ActiveMQConnectionFactory Unsupported major minor version 51 0

org apache activemq ActiveMQConnectionFactory Unsupported major minor version 51 0

If you are using Apache ActiveMQ version 5.11.1 with its client and getting below exception:

Exception in thread “main” java.lang.UnsupportedClassVersionError: org/apache/activemq/ActiveMQConnectionFactory : Unsupported major.minor version 51.0

Solution: Apache Active 5.11.1 has been compile with JDK 7 so minor major version issue occurs if it JDK version does not match. Change your project compiler to JDK 7.

2015-02-25_2207

Leave a Reply

Your email address will not be published. Required fields are marked *