Project facet Java not supported by server

Project facet Java not supported by server

Project facet Java 1.7 is not supported by this server.

Project facet Java 1.7 is not supported by this server

If you get Project facet Java 1.7 is not supported by this server when try add project to the server. It means project been configured on java 1.7 version and this version is not supported by the server. Please follow the below:

Step 1:

Right click your project –> Properties you will see below window:

Project_facet_Java_1.7_is_not_supported_by_this_server_3

Step 2:

Select Project Facet from left –> Click Java –> From the compiler complaince level drop down select JDK version is supported by your server –>Click OK

This should fix issue and you should be able to add project again on application server.

Leave a Reply

Your email address will not be published. Required fields are marked *