The selected JRE does not support the current compiler compliance level of 1.7

The selected JRE does not support the current compiler compliance level of 1.7

To fix above issue please follow below steps:

  • Open your eclipse
  • Click Window –> Java –> Installed JREs just to show you error message we are getting

The selected JRE does not support the current compiler compliance level of 1.7

 

  • Now click java –> Compiler — Compiler compliance level change it version 1.6. In my case my eclipse had installed version of JDK 1.6 but compiler compliance level was set to 1.7, change to versio 1.6 will match JDK installed version. Click Apply –> OK

The selected JRE does not support the current compiler compliance level of 1.7

 

  • This should fix the issue the selected JRE does not support the current compiler compliance level of 1.7

Leave a Reply

Your email address will not be published. Required fields are marked *